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Web UI Procedures
Version 3.1 and higher

1.0 Set up the MP2300iec and MP3000iec controllers (Firmware 3.x)

KEY INFORMATION The controller will be comissioned for a new project.

Scenario 1: Controller new in box

Scenario 2: Controller with unknown configuration

Step Description Detail

1 Install option modules
Use the battery cover to remove the module cover and module, if required, as 

illustrated in manual YEA-SIA-IEC-2 section 5.1.5.

2 Verify DIP switch setting
SW1 = all off except CNFG on.  SW2 = all off.  See table 1.03 below for more 

details.

3 Wire 24V DC Power Wire and install according to the hardware manual YEA-SIA-IEC-2

4
Establish ethernet 

communication with controller
See procedure 1.4 - type controller IP address into Internet Explorer

5 Login to WebUI
Login as Admin with password MP2300S, MP3300,  or MP3200  (case sensitive) 

See procedure 2.1.

6 Set IP address
Setup - "Ethernet Config".  Under "Built-in Ethernet" enter IP address and Subnet 

Mask and click "Save" to apply.

7 Set default gateway

Setup - "Ethernet Config".  Under "Default Gateway" enter IP address of gateway 

device.  If no gateway device exists on the network, enter the IP address of the 

controller again. Click "Save" to apply.

8 Set date and time
Setup - "Set Clock".  Adjust the date and time.  Check box "auto-run".  Click "Set" to 

apply.

9 Reboot Controller
Click "Reboot" and confirm with "Reboot" and "OK" to confirm.  Wait 45 seconds for 

reboot.

10 Upgrade firmware

The latest firmware should be loaded before application development.  For field 

replacement the firmware may be matched to the original firmware level.  (See 

procedure 2.5)

1.1 Set up the MP2600Siec controller (Firmware 2.x)

KEY INFORMATION The controller will be comissioned for a new project.

Scenario 1: Controller new in box

Scenario 2: Controller with unknown configuration

Step Description Detail

1 Install Battery for SRAM

Refer to Manual YEA-SIA-IEC-6 section 7.  Remove case, insert metal bracket, 

secure battery holder with screw.  Connect battery extension, slide battery in holder. 

Replace case, connect the battery.

2 Verify DIP switch setting
SW1 = all off except CNFG on.  SW2 = all off.  See table 1.03 below for more 

details.

3 Wire and Install Servo
Wire and install according to the corresponding Sigma-5 Option Manual such as 

SIEPS80000060, SIEPS80000066, SIEPS80000089, SIEPS80000098

4
Establish ethernet 

communication with controller

See procedure 1.4 - type controller IP address into Internet Explorer to open the 

controller's built in WebUI.

5 Login to WebUI Login as Admin/MP2600 (case sensitive) 

6 Set IP address
Setup - "Ethernet Config".  Under "Built-in Ethernet" enter IP address and Subnet 

Mask and click "Save" to apply.

7 Set default gateway

Setup - "Ethernet Config".  Under "Default Gateway" enter IP address of gateway 

device.  If no gateway device exists on the network, enter the IP address of the 

controller again. Click "Save" to apply.

8 Set date and time
Setup - "Set Clock".  Adjust the date and time.  Check box "auto-run".  Click "Set" to 

apply.

9 Initialize SRAM Initialize SRAM -> Re-initialize SRAM, OK

10 Reboot Controller
Click "Reboot" and confirm with "Reboot" and "OK" to confirm.  Wait 45 seconds for 

reboot.

11 Upgrade firmware
The latest firmware should be loaded before application development.  For field 

replacement upgrade to the original firmware level.  (See procedure 2.5)

Webserver Login
Admin / MP2600

WebUI Login
Admin / MP2300S, MP3300, 
MP3200, MP2600
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1.2 Set the Front Panel Switches

KEY INFORMATION CNFG normally ON, all others OFF

Switches only have an effect during power-on

Switches listed for MP2000iec products.  Refer to manual for MP3000iec series.

Switch Normal Setting Detail

STOP OFF
Immediately stops the program from executing. Required for test run from Hardware 

Configuration or Web Interface

SUP OFF
Boots the controller in "Supervisor mode" before a firmware update.  Supervisor 

mode can also be activated through the web interface

INIT OFF

Initializes SRAM contents, including retained variable data, clock, and absolute 

encoder offsets.  Useful when SRAM has been corrupted when lithium battery has 

been disconnected for a long time. 

Controller uses "default" hardware configuration.  Useful to recover if invalid 

"startup" configuration has been saved to controller.

CNFG ON

Discovers option modules and Mechatrolink devices at power-up.  May remain on. 

The discovered "disco" configuration is not used when the saved "startup" 

configuration exists.  The discovered configuration may be saved using 

MotionWorks IEC Hardware Configuration.

MON OFF For "network boot" or "ROM boot".  Leave OFF

LOAD OFF
Loads user project from connected USB flash drive when MNT=OFF.  Installs 

firmware and loads user project when MNT=ON.

TEST OFF
MP2000iec: For "system use" or "normal operation".  Leave OFF

MP3300iec: IP address is scrolled across front panel display

MNT OFF Controller starts in "Supervisor mode" before firmware update.

DHCP OFF Controller IP address is assigned by DHCP server on the network.

E-INIT OFF

Temporarily override the IP addresss with 192.168.1.1. Configured IP address is not 

affected.  MP2600iec Port B is set to 192.168.2.1.  MP3200iec IP address is affected 

by setting of E-PM0 and E-PM1.

E-PM0 OFF
MP3200iec only.  Temporarily override the IP address with 

192.168.1.RotarySwitches (when E-PM1 = OFF)

E-PM1 OFF
MP3200iec only. Controller IP address is assigned by DHCP server on the network 

(When E-PM0 = OFF)

E-TEST OFF Self Diagnosis of Ethernet.  Leave OFF>

1.3 Set IP Address of PC (Windows 7)

KEY INFORMATION

Step Description Detail

1 Open Network Connections

In windows 7, go to control panel, network and internet, network and sharing center, 

and on the left choose change adapter settings.  Alternative: Type "ncpa.cpl" in 

windows search.

2
Open Properties of the 

Connection

Find the connection you're using, such as Local Area Connection and right-click to 

choose properties

3
Enter static IP address in 

TCP/IPv4 properties.

Find "Internet Protocol Version 4 (TCP/IPv4)", then properties.  Change to "use the 

following IP address" and type in an IP address on the same subnet as the 

controller.  Example: If the MPiec controller is 192.168.1.1 by default, then the PC 

can be for example 192.168.1.50 .  The subnet mask will autofill with 255,255,255,0.  

Click ok for the setting to take effect.

4 Troubleshoot
Under the start button, type c-m-d.  Type ipconfig.  IP address information about 

your PC appears.

Page 3 of 24



MPiec Series QRG Rev 3.4

1.4 Establish Ethernet Communication between Controller and PC

KEY INFORMATION MP2000iec IP address = 192.168.1.1 when powered up with E-INIT dipswitch ON

This switch setting does not affect the controller program or the configured address

The IP address will revert to the configured address when the E-INIT dipswitch is 

OFF at power-up

Step Description Detail

1
Determine and set IP address of 

PC

See procedure above for PC.  Set IP address with required subnet, often the subnet 

is 1

2
Connect Ethernet Cables and 

apply power

If possible, simplify the ethernet connection  by disconnecting the controller from any 

network, and connect directly to the PC.

3
Determine IP address of 

Controller

Method 1: MotionWorks IEC project -> project tree,  physical hardware, right click 

resource, and choose settings.  

Method 2: MotionWorks IEC hardware configuration, TCP/IP settings

Method 3: Reboot controller with E-INIT switch ON to set 192.168.1.1 (MP2600iec 

Port A is 192.168.1.1 and Port B is 192.168.2.1).  

4 Open WebUI
Microsoft Internet Explorer, address bar, type the IP address of controller.  Default is 

192.168.1.1

5 Troubleshoot

Ping Test.  Under the start button, type c-m-d.  Type ping followed by the ip address 

of the controller.  For example, 192.168.1.1.  Ping test determines if there is any 

level of communication between PC and controller. 

1.5 Login to WebUI

KEY INFORMATION

Step Description Detail

1
Establish ethernet 

communication with controller

See procedure 1.4 - type controller IP address into Internet Explorer to open the 

controller's built in WebUI.

2 Enter Login Credentials

Login: Admin (case sensitive).  

Password: MP2300S (all caps, for MP2300Siec and MP2310iec).  

Password: MP2600 (all caps, for MP2600iec).  

Password: MP3200 (all caps, for MP3200iec)

Troubleshoot

The login configuration may have been customized.  Obtain the login information 

from the network administrator.  Otherwise, the controller may be reset to factory 

default using Motionworks IEC.  See procedure __

1.6 Set IP Address of Controller

KEY INFORMATION

Step Description Detail

1 Login to WebUI See Procedure.  Login: Admin.  Password: MP2300S, MP2600, MP3200, MP3300

2 Open "Ethernet Config" On the left side

3 Set IP address
Select "Ethernet Config".  Enter IP address and Subnet Mask. Click "Update Built-in 

Ethernet Settings" to save.

4 Set default gateway

Select "Ethernet Config".  Enter Default Gateway.  If not gateway device exists on 

the network, enter the same address as the IP address. Click "Update Built-in 

Ethernet Settings" to save.

5 Turn off E-INIT switch

E-INIT must be off for configured ethernet settings to take effect at next reboot.  If E-

INIT is left on, the address will be 192.168.1.1 regardless of the Ethernet Config 

settings.

6 Reboot Controller

Under "Maintenance" -> reboot, then "Reboot Controller" and "OK" to confirm.  Wait 

45 seconds for reboot.  The settings do not take effect until the controller is rebooted 

with E-INIT off.
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1.7 Update firmware

KEY INFORMATION
Do  NOT update firmware in the field unless directed by Yaskawa.

DO update firmware before code development begins on new application.

Step Description Detail

1
Establish ethernet 

communication with controller

See procedure 1.4 - type controller IP address into Internet Explorer to open the 

controller's built in WebUI.

2
Determine current firmware 

version

The WebUI welcome page lists the firmware version number, build number, and 

build date

3 Acquire a firmware zip file yaskawa.com/iecfw to download firmware files.  Must log in to yaskawa.com

4 Login to WebUI See Procedure.  Login: Admin.  Password: MP2300S, MP2600, MP3200, MP3300

5 Stop all motion Operate the machine according to existing program.

6 Enable supervisor mode
Under "Maintenance" -> "Update Firmware", then click "enabled via software" and 

"reboot controller". Wait 45 seconds for reboot.

7 Load firmware zip file
Under "Maintenance" -> "Update Firmware", then browse for firmware file, and 

"upload".  Upload takes about 1 minute. Do not attempt to unzip the firmware file.

8 Update firmware
Confirm the update version.  Then click "update" button.  The update takes about 2 

minutes.  Do not use the controller during this time.

9 Reboot Controller
Under "Maintenance" -> reboot, then "Reboot Controller" and "OK" to confirm.  Wait 

45 seconds for reboot.

1.8 Receive Project Archive (Back up controller and servo parameters)

KEY INFORMATION The project archive contains the critical data for the controller and servopacks.

Save this archive at time of machine comissioning and after any change is made.

Step Description Detail

1 Login to WebUI See Procedure.  Login: Admin.  Password: MP2300S, MP2600, MP3200, MP3300

2 Verifiy Drive Parameters

Drive Parameters -> User Parameters, "verify" each axis.  Verify compares 

parameters in the archive with the current parameters in the servo.  IF Verify is 

successful, proceed to next step.  IF Verify is not successful, then the archive drive 

parameters do not match the current parameters in the servos.  Use MotionWorks 

IEC hardware configuration to import parameters to project archive.

3 Save archive from controller
Setup -> Archive -> "Receive", rename  as required.  *.zip file is saved to browser's 

default download directory.

1.9 Send Project Archive

KEY INFORMATION This procedure only  sends the controller program and configuration.

Step Description Detail

1 Login to WebUI See Procedure.  Login: Admin.  Password: MP2300S, MP2600, MP3200, MP3300

2 Obtain the project archive file
*.zip is the file extention.  The project archive must  have been previously saved 

from an existing controller.  It can also be created by MotionWorks IEC.

3 Send archive to controller

Project Archive -> "Browse" and select the project archive file.  Select "Clean Install" 

to delete any previous archive files.  Then "Send to Controller", "OK".  Wait 1-2 

minutes.  When complete the button changes from "Wait" back to "Send to 

Controller".

4 Reboot
Under "Maintenance" -> reboot, then "Reboot Controller" and "OK" to confirm.  Wait 

45 seconds for reboot.
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1.A Startup from Project Archive

KEY INFORMATION
Project Archive contains all required data including servo parameters.

Archive is not active until reboot.

Step Description Detail

1 Set up the controller See procedure 1.0, for new controllers.

2 Stop all motion Operate the machine according to existing program.

3 Login to WebUI See Procedure.  Login: Admin.  Password: MP2300S, MP2600, MP3200, MP3300

4 Obtain the project archive file
*.zip is the file extention.  The project archive must  have been previously saved 

from an existing controller.  It can also be created by MotionWorks IEC.

5 Send archive to controller

Setup - Archive - Send - Add Archive.  Navigate to select the project archive file.   

"Clean Install" to delete all previous archive files.  Click "Send", wait for transfer 

"Install".  "Installing Archive" message appears at the top.  When complete, the 

message dissappears and the archive files are displayed.

6 Reboot #1
Status -> Reboot and confirm with "Reboot".  Wait 45 seconds for reboot.  

Controller is now running the loaded archive but may have alarms.

7 Send Drive Parameters

Setup - Drive Parameters.  Under "User Parameters", click "verify" for each axis.  

Verify compares parameters in the archive with the current parameters in the servo 

drive.  Click "Write" and confirm "Write" to send parameters from archive to servo. 

Takes 1-2 seconds to write. "Verified" confirms success.

8 Reboot #2
Status -> Reboot and confirm with "Reboot".  Wait 45 seconds for reboot.  Servos 

are now using the drive parameters sent from the archive.

9
Initialize Absolute Encoders to 

clear A.810, A.820, A.CC0

Operations - Motion Control Panel.  Click "Download and run externally" and run 

"WebControllerApplet". Java opens, "Run", new window titled Yaskawa Engineering 

Tool opens.  Navigate to "Drive Pn" tab -> select the axis with the encoder alarm.  

Click "abs encoder init"  then "Multiturn Reset".  Alarms A.810, A.820 and A.CC0 

will clear after reboot.

10 Reboot #3
Status -> Reboot and confirm with "Reboot".  Wait 45 seconds for reboot.  Encoder 

alarms are now clear, and Pn205 multiturn limit has been stored in the encoder.

11
Zero-Set / Home and machine 

calibration

Follow steps according to application programming of machine.  Home offsets for 

absolute encoder are stored in SRAM of controller .
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1.B Clear Alarm A.810 (Initialize Absolute Encoders)

KEY INFORMATION

Alarm A.810 means that the absolute encoder of the servomotor lost the position 

during power off because BATTERY power was lost to the servomotor, invalidating 

the absolute position.

The alarm can by cleared by: 1) Web Server.  2) Y_ResetAbsoluteEncoder function 

block, 3) SigmaWin+ software, 3) Fn008 (Digital Operator). 

Step Description Detail

1 Login to WebUI See Procedure.  Login: Admin.  Password: MP2300S, MP2600, MP3200, MP3300

2 Initialize absolute encoder

Operations - Motion Control Panel.  Click "Download and run externally" and run 

"WebControllerApplet". Java opens, "Run", new window titled Yaskawa Engineering 

Tool opens.  Navigate to "Drive Pn" tab -> select the axis with the encoder alarm.  

Click "abs encoder init"  Alarms A.810, A.820 and A.CC0 will clear after reboot.

3
Reboot Controller and Sigma5 

Servopack

Under "Maintenance" -> reboot, then "Reboot Controller" and "OK" to confirm.  Wait 

45 seconds for reboot.

4
Zero-Set / Home and machine 

calibration

Follow steps according to application programming of machine.  Home offsets for 

absolute encoder are stored in SRAM of controller .

1.C Clear Alarm A.CC0

KEY INFORMATION

Alarm A.CC0 means that the servomotor's absolute encoder Multi-turn Limit 

(Rollover) setting does not match the Multi-turn Limit setting of the servopack 

(Pn205).  The parameter can be sent from servopack to encoder by: 1) Web Server.  

2) Y_ResetAbsoluteEncoder function block, 3) SigmaWin+ software, 3) Fn00C 

(Digital Operator). 

Step Description Detail

1 Login to WebUI See Procedure.  Login: Admin.  Password: MP2300S, MP2600, MP3200, MP3300

2
Reset multiturn limit on absolute 

encoder

Operations - Motion Control Panel.  Click "Download and run externally" and run 

"WebControllerApplet". Java opens, "Run", new window titled Yaskawa Engineering 

Tool opens.  Navigate to "Drive Pn" tab -> select the axis with the encoder alarm.  

Click "Multiturn Reset".  Alarms A.810, A.820 and A.CC0 will clear after reboot.

3
Reboot Controller and Sigma5 

Servopack
Status -> Reboot and confirm with "Reboot".  Wait 45 seconds for reboot..

4
Zero-Set / Home and machine 

calibration

Follow steps according to application programming of machine.  Home offsets for 

absolute encoder are stored in SRAM of controller .

1.D Replace the controller

KEY INFORMATION MotionWorks IEC software is NOT required

The new controller must match the old in the following areas:

1.  IP address , 2. SRAM, 3. Firmware, 4.Project Archive

Step Description Detail

1 Set up the controller See procedure 1.0

2 Load Project Archive See procedure   .  WebUI: Project Archive -> "Browse", "Clean Install"

3 Reboot Controller Status -> Reboot and confirm with "Reboot".  Wait 45 seconds for reboot.

4
Zero-Set / Home and machine 

calibration

Follow steps according to application programming of machine.  Home offsets for 

absolute encoder are stored in SRAM of controller .
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1.E Replace a Servopack (Mechatrolink)

KEY INFORMATION: 

Step Description Detail

1
Install the replacement 

servopack
Power supply, motor, encoder, Mechatrolink, IO, holding brake, regen resistors, etc

2 Set the Mechatrolink Address
Note the rotary address switch setting of existing servopack and set the same 

address to the replacement servopack.

3 Login to WebUI
See Procedure.  Login: Admin.  Password: MP2300S,  MP3200, MP3300

Expect controller alarm 3301 000b "Pn002 not correctly initialized"

4 Send Drive Parameters

Setup -> Drive Parameters ->  "verify" each axis.  Verify compares parameters in the 

archive with the current parameters in the servo.  "Write" and "OK" to send 

parameters from archive to servo. Takes just a couple seconds to write.

5 Reboot Status -> Reboot and confirm with "Reboot".  Wait 45 seconds for reboot.

1.F Replace ServoMotor

KEY INFORMATION: Absolute encoder alarms require special consideration (A.810 and A.CC0)

Power OFF

Install replacement motor 

Clear Alarm A.810 See procedure 1.B.  Only applies to absolute encoder.

Clear Alarm A.CC0 See procedure 1.C.  Only to Absolute Encoder when multi-turn limit Pn205 is set

Reboot Controller and Sigma5 

Servopack
Status -> Reboot and confirm with "Reboot".  Wait 45 seconds for reboot..

Zero-Set / Home and machine 

calibration

Follow steps according to application programming of machine.  Home offsets for 

absolute encoder are stored in SRAM of controller .

Available methods to clear A.810 

& A.CC0

1 Project: Integrate the Y_ResetAbsoluteEncoder function block into your code

2
WebUI: Machine Operations, DrivePn tab - select axis number, click "Abs Encoder 

Init" / "Multiturn Reset"
3

MWIEC Hardware Configuration: Online, Under Mechatrolink-II click on axis, click 

"Reset Absolute Encoder" 
4 SigmaWin+ : Setup - Absolute Encoder

5 Digital Operator: Fn008-> PgCl5 ( and Fn013 (multi-turn reset)

1.G Replace Battery

KEY INFORMATION: 

There is one battery in the controller, and also a battery in the cable of an absolute 

encoder motor

Replace absolute encoder battery while power is on - no further action required

Replace absolute encoder battery while power is off - See precedure 2.7 "replace servomotor"

1.H Machine Operations and JAVA version

KEY INFORMATION: 

JAVA is an ever-changing technology with security updates that compromise the 

functionality of the web server.

Search Yaskawa.com keyword "Java" for the latest fixes.  (Example, FAQ # 
Step Description Detail

1 Open Java Control Panel Windows 7: Control Panel\Programs.  Open "Java"

2 Change security to medium Navigate to "security" tab.  Set slider to medium.

3
Add controller IP address to 

Exception Site List

Click "Edit Site List", "Add", type "http://" in front of the IP address of the controller 

(eg. http://192.168.1.1).  Click OK and continue to accept the warning.

4 Restart Internet Explorer

The Servopack parameters can also be written

* From the controller, automatically, according to the controller program

* From MotionWorks IEC project file

* From a previously saved SigmaWin+ parameter file

Replace controller battery with power ON or OFF.  

Do not leave controller power off without battery for more than 1 hour, to avoid corruption of SRAM data.
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1.i Test Move 

KEY INFORMATION: 

Step Description Detail

1
Restore system from project 

archive

See section 1.A.  The servo parameters must be set and the absolute encoders 

must be reset.

2 Clear servo alarms
Many alarms can be cleared in the alarm menu. See section 1.B and 1.D for 

encoder alarms, which also require a reboot to clear.

3 Stop the controller program

Either 1) turn on the STOP switch on the controller front panel, 2) use the STOP 

button within the MotionWorks IEC environment, or 3) temporarily delete the archive 

and reboot (save the archive before deleting).

4 Open "Motion Control Panel"

Operations - Motion Control Panel.  Click "Download and run externally" and run 

"WebControllerApplet". Java opens, "Run", new window "Yaskawa Engineering 

Tool" opens.

5 Move the motors

The axes are listed by name (or number) in columns.  The feedback position and 

target position are given in configured user units.  Target Vel is set to 1 rev/sec in 

user units.  Accel Limit and Decel Limit are set to 1 rev/sec^2 in user units.  Check 

the box "Enable".  Set "Target Pos" to the desired absolute position.  Click the 

"Move" button.  To stop, click the "Abort" button or uncheck the box "Enable".  The 

servo will move to the absolute position and stop when Feedback Pos = Target Pos.

6 Run the controller program
Turn off the stop switch on the controller front panel, install the saved archive if it 

was deleted, and reboot the controller.

The test move confirms that the MPiec controller can run each servo axis.

If successful, then application problems are related to the program or connected devices.

If not successful, problems are likely related to servo wiring or parameter configuration
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Web Sever Procedures
MP2000iec Series Controllers version 3.0 and lower

1.0 Set up the MP2300Siec and MP2310iec controller (Firmware 2.x)

KEY INFORMATION The controller will be comissioned for a new project.

Scenario 1: Controller new in box

Scenario 2: Controller with unknown configuration

Step Description Detail

1 Install option modules
Use the battery cover to remove the module cover and module, if required, as 

illustrated in manual YEA-SIA-IEC-2 section 5.1.5.

2 Verify DIP switch setting
SW1 = all off except CNFG on.  SW2 = all off.  See table 1.03 below for more 

details.

3 Wire 24V DC Power Wire and install according to the hardware manual YEA-SIA-IEC-2

4
Establish ethernet 

communication with controller
See procedure 1.4 - type controller IP address into Internet Explorer

5 Login to Webserver Login as Admin/MP2300S (case sensitive) See procedure 2.1.

6 Set IP address
Select "Ethernet Config".  Enter IP address and Subnet Mask. Click "Update Built-in 

Ethernet Settings".

7 Set default gateway

Select "Ethernet Config".  Enter Default Gateway.  If not gateway device exists on 

the network, enter the same address as the IP address. Click "Update Built-in 

Ethernet Settings".

8 Set date and time
Select "Set Clock".  Adjust the date and time.  Check box "auto-run".  Click "Set 

Date/Time" to apply.

9 Reboot Controller
Under "Maintenance" -> reboot, then "Reboot Controller" and "OK" to confirm.  Wait 

45 seconds for reboot.

10 Upgrade firmware

The latest firmware should be loaded before application development.  For field 

replacement the firmware may be matched to the original firmware level.  (See 

procedure 2.5)

1.1 Set up the MP2600Siec controller (Firmware 2.x)

KEY INFORMATION The controller will be comissioned for a new project.

Scenario 1: Controller new in box

Scenario 2: Controller with unknown configuration

Step Description Detail

1 Install Battery for SRAM

Refer to Manual YEA-SIA-IEC-6 section 7.  Remove case, insert metal bracket, 

secure battery holder with screw.  Connect battery extension, slide battery in holder. 

Replace case, connect the battery.

2 Verify DIP switch setting
SW1 = all off except CNFG on.  SW2 = all off.  See table 1.03 below for more 

details.

3 Wire and Install Servo
Wire and install according to the corresponding Sigma-5 Option Manual such as 

SIEPS80000060, SIEPS80000066, SIEPS80000089, SIEPS80000098

4
Establish ethernet 

communication with controller

See procedure 1.4 - type controller IP address into Internet Explorer to open the 

controller's built in webserver.

5 Login to Webserver Login as Admin/MP2600 (case sensitive) 

6 Set IP address
Select "Ethernet Config".  Enter IP address and Subnet Mask. Click "Update Built-in 

Ethernet Settings".

7 Set default gateway

Select "Ethernet Config".  Enter Default Gateway.  If no gateway device exists on the 

network, enter the same address as the IP address. Click "Update Built-in Ethernet 

Settings".

8 Set date and time
Select "Set Clock".  Adjust the date and time.  Check box "auto-run".  Click "Set 

Date/Time" to apply.

9 Initialize SRAM Initialize SRAM -> Re-initialize SRAM, OK

10 Reboot Controller
Under "Maintenance" -> reboot, then "Reboot Controller" and "OK" to confirm.  Wait 

45 seconds for reboot.

11 Upgrade firmware
The latest firmware should be loaded before application development.  For field 

replacement upgrade to the original firmware level.  (See procedure 2.5)

Webserver Login
Admin / MP2600

WebServer Login
Admin / MP2300S
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1.2 Set the Front Panel Switches

KEY INFORMATION CNFG normally ON, all others OFF

Switches only have an effect during power-on

Switches listed for MP2000iec products.  Refer to manual for MP3000iec series.

Switch Normal Setting Detail

STOP OFF
Immediately stops the program from executing. Required for test run from Hardware 

Configuration or Web Interface

SUP OFF
Boots the controller in "Supervisor mode" before a firmware update.  Supervisor 

mode can also be activated through the web interface

INIT OFF

Initializes SRAM contents, including retained variable data, clock, and absolute 

encoder offsets.  Useful when SRAM has been corrupted when lithium battery has 

been disconnected for a long time. 

Controller uses "default" hardware configuration.  Useful to recover if invalid 

"startup" configuration has been saved to controller.

CNFG ON

Discovers option modules and Mechatrolink devices at power-up.  May remain on. 

The discovered "disco" configuration is not used when the saved "startup" 

configuration exists.  The discovered configuration may be saved using 

MotionWorks IEC Hardware Configuration.

MON OFF For "network boot" or "ROM boot".  Leave OFF

TEST OFF For "system use" or "normal operation".  Leave OFF

E-INIT OFF
Temporarily override the IP addresss with 192.168.1.1. Configured IP address is not 

affected.  MP2600iec Port B is set to 192.168.2.1 

E-TEST OFF Self Diagnosis of Ethernet.  Leave OFF>

1.3 Set IP Address of PC (Windows 7)

KEY INFORMATION

Step Description Detail

1 Open Network Connections

In windows 7, go to control panel, network and internet, network and sharing center, 

and on the left choose change adapter settings.  Alternative: Type "ncpa.cpl" in 

windows search.

2
Open Properties of the 

Connection

Find the connection you're using, such as Local Area Connection and right-click to 

choose properties

3
Enter static IP address in 

TCP/IPv4 properties.

Find "Internet Protocol Version 4 (TCP/IPv4)", then properties.  Change to "use the 

following IP address" and type in an IP address on the same subnet as the 

controller.  Example: If the MPiec controller is 192.168.1.1 by default, then the PC 

can be for example 192.168.1.50 .  The subnet mask will autofill with 255,255,255,0.  

Click ok for the setting to take effect.

4 Troubleshoot
Under the start button, type c-m-d.  Type ipconfig.  IP address information about 

your PC appears.

1.4 Establish Ethernet Communication between Controller and PC

KEY INFORMATION MP2000iec IP address = 192.168.1.1 when powered up with E-INIT dipswitch ON

This switch setting does not affect the controller program or the configured address

The IP address will revert to the configured address when the E-INIT dipswitch is 

OFF at power-up

Step Description Detail

1
Determine and set IP address of 

PC

See procedure above for PC.  Set IP address with required subnet, often the subnet 

is 1

2
Connect Ethernet Cables and 

apply power

If possible, simplify the ethernet connection  by disconnecting the controller from any 

network, and connect directly to the PC.

3
Determine IP address of 

Controller

Method 1: MotionWorks IEC project -> project tree,  physical hardware, right click 

resource, and choose settings.  

Method 2: MotionWorks IEC hardware configuration, TCP/IP settings

Method 3: Reboot controller with E-INIT switch ON to set 192.168.1.1 (MP2600iec 

Port A is 192.168.1.1 and Port B is 192.168.2.1).  

4 Open Webserver
Microsoft Internet Explorer, address bar, type the IP address of controller.  Default is 

192.168.1.1

5 Troubleshoot

Ping Test.  Under the start button, type c-m-d.  Type ping followed by the ip address 

of the controller.  For example, 192.168.1.1.  Ping test determines if there is any 

level of communication between PC and controller. 
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1.5 Login to Webserver

KEY INFORMATION

Step Description Detail

1
Establish ethernet 

communication with controller

See procedure 1.4 - type controller IP address into Internet Explorer to open the 

controller's built in webserver.

2 Enter Login Credentials

Login: Admin (case sensitive).  

Password: MP2300S (all caps, for MP2300Siec and MP2310iec).  

Password: MP2600 (all caps, for MP2600iec).  

Password: MP3200 (all caps, for MP3200iec)

Troubleshoot

The login configuration may have been customized.  Obtain the login information 

from the network administrator.  Otherwise, the controller may be reset to factory 

default using Motionworks IEC.  See procedure __

1.6 Set IP Address of Controller

KEY INFORMATION

Step Description Detail

1 Login to Webserver See Procedure.  Login: Admin.  Password: MP2300S, MP2600, MP3200, MP3300

2 Open "Ethernet Config" On the left side

3 Set IP address
Select "Ethernet Config".  Enter IP address and Subnet Mask. Click "Update Built-in 

Ethernet Settings" to save.

4 Set default gateway

Select "Ethernet Config".  Enter Default Gateway.  If not gateway device exists on 

the network, enter the same address as the IP address. Click "Update Built-in 

Ethernet Settings" to save.

5 Turn off E-INIT switch

E-INIT must be off for configured ethernet settings to take effect at next reboot.  If E-

INIT is left on, the address will be 192.168.1.1 regardless of the Ethernet Config 

settings.

6 Reboot Controller

Under "Maintenance" -> reboot, then "Reboot Controller" and "OK" to confirm.  Wait 

45 seconds for reboot.  The settings do not take effect until the controller is 

rebooted with E-INIT off.

1.7 Update firmware

KEY INFORMATION
Do  NOT update firmware in the field unless directed by Yaskawa.

DO update firmware before code development begins on new application.

Step Description Detail

1
Establish ethernet 

communication with controller

See procedure 1.4 - type controller IP address into Internet Explorer to open the 

controller's built in webserver.

2
Determine current firmware 

version

The webserver welcome page lists the firmware version number, build number, and 

build date

3 Acquire a firmware zip file yaskawa.com/iecfw to download firmware files.  Must log in to yaskawa.com

4 Login to Webserver See Procedure.  Login: Admin.  Password: MP2300S, MP2600, MP3200, MP3300

5 Stop all motion Operate the machine according to existing program.

6 Enable supervisor mode
Under "Maintenance" -> "Update Firmware", then click "enabled via software" and 

"reboot controller". Wait 45 seconds for reboot.

7 Load firmware zip file
Under "Maintenance" -> "Update Firmware", then browse for firmware file, and 

"upload".  Upload takes about 1 minute. Do not attempt to unzip the firmware file.

8 Update firmware
Confirm the update version.  Then click "update" button.  The update takes about 2 

minutes.  Do not use the controller during this time.

9 Reboot Controller
Under "Maintenance" -> reboot, then "Reboot Controller" and "OK" to confirm.  Wait 

45 seconds for reboot.
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1.8 Save Project Archive (Backup controller and servo parameters)

KEY INFORMATION The project archive contains the critical data for the controller and servopacks.

Save this archive at time of machine comissioning and after any change is made.

Step Description Detail

1 Login to Webserver See Procedure.  Login: Admin.  Password: MP2300S, MP2600, MP3200, MP3300

2 Verifiy Drive Parameters

Drive Parameters -> User Parameters, "verify" each axis.  Verify compares 

parameters in the archive with the current parameters in the servo.  IF Verify is 

successful, proceed to next step.  IF Verify is not successful, then the archive drive 

parameters do not match the current parameters in the servos.  Use MotionWorks 

IEC hardware configuration to import parameters to project archive.

3 Save archive from controller
Project Archive -> "Browse" and select the project archive file.  Then "Receive from 

Controller".  Navigate to directory on PC to save *.zip file.

1.9 Load Project Archive

KEY INFORMATION This procedure only  sends the controller program and configuration.

Step Description Detail

1 Login to Webserver See Procedure.  Login: Admin.  Password: MP2300S, MP2600, MP3200, MP3300

2 Obtain the project archive file
*.zip is the file extention.  The project archive must  have been previously saved 

from an existing controller.  It can also be created by MotionWorks IEC.

3 Send archive to controller

Project Archive -> "Browse" and select the project archive file.  Select "Clean Install" 

to delete any previous archive files.  Then "Send to Controller", "OK".  Wait 1-2 

minutes.  When complete the button changes from "Wait" back to "Send to 

Controller".

4 Reboot
Under "Maintenance" -> reboot, then "Reboot Controller" and "OK" to confirm.  Wait 

45 seconds for reboot.

1.A Startup from Project Archive

KEY INFORMATION
Project Archive contains all required data including servo parameters.

Archive is not active until reboot.

Step Description Detail

1 Set up the controller See procedure 1.0, for new controllers.

2 Stop all motion Operate the machine according to existing program.

3 Login to Webserver See Procedure.  Login: Admin.  Password: MP2300S, MP2600, MP3200, MP3300

4 Obtain the project archive file
*.zip is the file extention.  The project archive must  have been previously saved 

from an existing controller.  It can also be created by MotionWorks IEC.

5 Send archive to controller

Project Archive -> Browse, select the project archive file.   "Clean Install" to delete 

any previous archive files.  Then "Send to Controller", "OK".  Wait 1-2 minutes.  

When complete the button changes from "Wait" back to "Send to Controller".

6 Send Drive Parameters

Drive Parameters -> User Parameters, "verify" each axis.  Verify compares 

parameters in the archive with the current parameters in the servo.  "Write" and 

"OK" to send parameters from archive to servo. Takes just a couple seconds to 

write.

7 Reboot #1
Under "Maintenance" -> reboot, then "Reboot Controller" and "OK" to confirm.  Wait 

45 seconds for reboot.

8
Initialize Absolute Encoders to 

clear A.810, A.820, A.CC0

Machine Operations.  Determine which axis number has the alarm. Drive PN tab -> 

pull down to select the axis number.  Click "abs encoder init"  then "Multiturn 

Reset".  Clears alarms A.810 and A.CC0.

9 Reboot #2
Under "Maintenance" -> reboot, then "Reboot Controller" and "OK" to confirm.  Wait 

45 seconds for reboot.

10
Zero-Set / Home and machine 

calibration

Follow steps according to application programming of machine.  Home offsets for 

absolute encoder are stored in SRAM of controller .
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1.B Clear Alarm A.810 (Initialize Absolute Encoders)

KEY INFORMATION

Alarm A.810 means that the absolute encoder of the servomotor lost the position 

during power off because BATTERY power was lost to the servomotor, invalidating 

the absolute position.

The alarm can by cleared by: 1) Web Server.  2) Y_ResetAbsoluteEncoder function 

block, 3) SigmaWin+ software, 3) Fn008 (Digital Operator). 

Step Description Detail

1 Login to Webserver See Procedure.  Login: Admin.  Password: MP2300S, MP2600, MP3200, MP3300

2 Initialize absolute encoder
Machine Operations.  Determine which axis number has the alarm. Drive PN tab, 

pull down to select the axis number.  Click "abs encoder init" button.

3
Reboot Controller and Sigma5 

Servopack

Under "Maintenance" -> reboot, then "Reboot Controller" and "OK" to confirm.  Wait 

45 seconds for reboot.

4
Zero-Set / Home and machine 

calibration

Follow steps according to application programming of machine.  Home offsets for 

absolute encoder are stored in SRAM of controller .

1.C Clear Alarm A.CC0

KEY INFORMATION

Alarm A.CC0 means that the servomotor's absolute encoder Multi-turn Limit 

(Rollover) setting does not match the Multi-turn Limit setting of the servopack 

(Pn205).  The parameter can be sent from servopack to encoder by: 1) Web Server.  

2) Y_ResetAbsoluteEncoder function block, 3) SigmaWin+ software, 3) Fn00C 

(Digital Operator). 

Step Description Detail

1 Login to Webserver See Procedure.  Login: Admin.  Password: MP2300S, MP2600, MP3200, MP3300

2 Initialize absolute encoder
Machine Operations.  Determine which axis number has the alarm. Drive PN tab, 

pull down to select the axis number.  Click "Multiturn Reset" button.

3
Reboot Controller and Sigma5 

Servopack

Under "Maintenance" -> reboot, then "Reboot Controller" and "OK" to confirm.  Wait 

45 seconds for reboot.

4
Zero-Set / Home and machine 

calibration

Follow steps according to application programming of machine.  Home offsets for 

absolute encoder are stored in SRAM of controller .

1.D Replace the controller

KEY INFORMATION MotionWorks IEC software is NOT required

The new controller must match the old in the following areas:

1.  IP address , 2. SRAM, 3. Firmware, 4.Project Archive

Step Description Detail

1 Set up the controller See procedure 1.0

2 Load Project Archive See procedure   .  Webserver: Project Archive -> "Browse", "Clean Install"

3 Reboot Controller
Under "Maintenance" -> reboot, then "Reboot Controller" and "OK" to confirm.  Wait 

45 seconds for reboot.

4
Zero-Set / Home and machine 

calibration

Follow steps according to application programming of machine.  Home offsets for 

absolute encoder are stored in SRAM of controller .

1.E Replace a Servopack (Mechatrolink)

KEY INFORMATION: 

Step Description Detail

1
Install the replacement 

servopack
Power supply, motor, encoder, Mechatrolink, IO, holding brake, regen resistors, etc

2 Set the Mechatrolink Address
Note the rotary address switch setting of existing servopack and set the same 

address to the replacement servopack.

3 Login to Webserver
See Procedure.  Login: Admin.  Password: MP2300S,  MP3200, MP3300

Expect controller alarm 3301 000b "Pn002 not correctly initialized"

4 Send Drive Parameters

Drive Parameters -> User Parameters, "verify" each axis.  Verify compares 

parameters in the archive with the current parameters in the servo.  "Write" and 

"OK" to send parameters from archive to servo. Takes just a couple seconds to 

write.

5 Reboot
Under "Maintenance" -> reboot, then "Reboot Controller" and "OK" to confirm.  Wait 

45 seconds for reboot.

The Servopack parameters can also be written

* From the controller, automatically, according to the controller program

* From MotionWorks IEC project file

* From a previously saved SigmaWin+ parameter file
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1.F Replace ServoMotor

KEY INFORMATION: 

Absolute encoder requires special consideration: 

Power OFF

Install replacement motor (mount, couple, wire) and Power ON

Clear Alarm A.810 (Absolute Encoder Only)

Clear Alarm A.CC0 (Only with Absolute Encoder and multi-turn limit Pn205 set)

Cycle Power to finish clearing alarm A.810 / A.CC0

Re-Calibrate axis position to mechanical zero

Stores absolute encoder offset in controller SRAM.  Updates incremental encoder 

offsets

Available methods to clear A.810 & A.CC0

1 Project: Integrate the Y_ResetAbsoluteEncoder function block into your code

2 WebServer: Machine Operations, DrivePn tab - select axis number, click "Abs 

3
MWIEC Hardware Configuration: Online, Under Mechatrolink-II click on axis, click 

"Reset Absolute Encoder" 
4 SigmaWin+ : Setup - Absolute Encoder

5 Digital Operator: Fn008-> PgCl5 ( and Fn013 (multi-turn reset)

1.G Replace Battery

KEY INFORMATION: 

There is one battery in the controller, and also a battery in the cable of an absolute 

encoder motor

Replace absolute encoder battery while power is on - no further action required

Replace absolute encoder battery while power is off - See precedure 2.7 "replace servomotor"

1.H Machine Operations and JAVA version

KEY INFORMATION: 

JAVA is an ever-changing technology with security updates that compromise the 

functionality of the web server.

Search Yaskawa.com keyword "Java" for the latest fixes.  (Example, FAQ # 
Step Description Detail

1 Open Java Control Panel Windows 7: Control Panel\Programs.  Open "Java"

2 Change security to medium Navigate to "security" tab.  Set slider to medium.

3
Add controller IP address to 

Exception Site List

Click "Edit Site List", "Add", type "http://" in front of the IP address of the controller 

(eg. http://192.168.1.1).  Click OK and continue to accept the warning.

4 Restart Internet Explorer

Replace controller battery with power ON or OFF.  

Do not leave controller power off without battery for more than 1 hour, to avoid corruption of SRAM data.
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MotionWorks IEC Procedures
For the MPiec Series Controllers

2.0 Start MotionWorks IEC

Step Description Detail

1 Double-Click the shortcut icon. 
During installation, a shortcut is placed on the desktop.  If the shortcut is not visible, 

find it under Start -> Programs -> Yaskawa

2.1 Open a saved project

KEY INFORMATION: 
Working projects constist of *.mwt (or *.mwe) file AND corresponding project folder.

The project may also be launched from Windows directly from the *.mwt (or *.mwe) 

file.

1 Start MotionWorks IEC See procedure.  Start -> Programs -> Yaskawa

2 Exit current project
File -> Close Project.  You will be prompted to save changes.  If appropriate, click 

"yes" to save the current project before closing.

3 Open Project
File -> Open Project.  Navigate to project directory and open *.mwt file (*.mwe for 

Express version)

2.2 Open a zipped project

KEY INFORMATION: 
Zipped projects consist of *.zwt (or *.zwe) file and must be extracted within 

MotionWorks IEC.  DO NOT USE WinZip, WinRar, or other software.

1 Start MotionWorks IEC See procedure.  Start -> Programs -> Yaskawa

2 Exit current project
(best practice) File -> Close Project.  You will be prompted to save changes.  If 

appropriate, click "yes" to save the current project before closing.

3 Open Project
File -> Open Project.  Navigate to project directory and open *.zwt file (*.zwe for 

Express version)

4 Choose unzip directory
Answer "NO" to the question "would you like to unzip to the folder containint the .zwt 

file?"   Navigate to the desired unzip directory and Save.

5 User Library overwrite options
Usually answer "No to all" for Possible prompt "Library '<name>' already exists! 

Overwrite?

6
Firmware Library overwrite 

options

Usually answer "Skip All" for possible prompt "The project contains firmware 

libraries T"

7 Page Layout options Answer "Yes to All" for pagelayout overwrite.  This feature is not used.

2.3 Start a new project

Step Description Detail

1 Start MotionWorks IEC See procedure. Start -> Programs -> Yaskawa

2 New Project File -> New Project

3 Choose Template Template according to controller type, OK

4 Rename Project (Best Practice)  File -> Save As

2.4 Save and Backup Project

KEY INFORMATION: 
The project is automatically saved every time "Make" is performed.

'Save as Zip' during development as backup.

Step Description Detail

1 Save Project as Zip File -> Save Project As / Zip Project As. Save as type 'Zipped Project Files (*.zwt)'.

2 Check Zip Options

By default check only 'Zip User-Libraries' and 'Zip Frontend-Code'.  "User-

Libraries" are the library project files you may have inserted into the Libraries folder 

of the project.  "Frontend-Code" is the compiled code.

3 Adjust Name
If this is a backup, add a version number or description to the file name.  Otherwise 

keep the name of the project.

4 Complete
Click Save to complete the zip operation.  OK to message "Project successful 

zipped!"

NOTE: Be sure there is no 
"dot" in the file path

NOTE: Be sure there is no 
"dot" in the file path
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2.5 Set Project IP Address (Connect project to controller)

KEY INFORMATION: 

Step Description Detail

1
Establish ethernet 

communication with controller

See procedure 1.4 - type controller IP address into Internet Explorer to open the 

controller's built in webserver.

2
Start a new project or open 

saved project
See Procedure.

3 Open Resource Settings Project Tree Window -> Hardware Tab, R-Click "Resource" -> choose "Settings"

4 Set controller IP address
Set the IP address "Parameter" to the address of the controller.  This is the same 

address used in the webserver in Step 1

5 Open Resource Window
Online -> Project Control.  Resource window opens.  Resource is the controller 

(PLC).  The project is now communicating with the PLC.

2.6 Reset the MPiec controller back to factory settings

KEY INFORMATION: 

Required only when starting a new application with a controller that is not new.

The controller,  servopack  and servomotor  are reset individually in MotionWorks 

IEC

Step Description Detail

1
Establish ethernet 

communication with controller

See procedure 1.4 - type controller IP address into Internet Explorer to open the 

controller's built in webserver.

2
Start a new MotionWorks IEC 

Project

File -> New Project.  Select template according to controller type, OK.  File -> Save 

As.  Navigate to required directory and name the project.

3
Open MotionWorks IEC 

Hardware Configuration
Click the Hardware Configuration Icon to open

4
Go Online with Hardware 

configuration

Enter the IP address of the controller.  Then click the "connect" button. Select "Use 

Offline Configuration" or "Use Online Configuration" or "Use Startup Configuration"

5
Go Offline with Hardware 

Configuration
Click "Disconnect"

6
Open Controller Configuration 

Utilities
Select the menu "Online"-Controller Configuration Utilities.  Must be offline.

7
Use the "Online" menu to restore 

to factory defaults
Execute "Restore controller to factory defaults then reboot controller", OK, Yes

8 Reboot controller The controller reboots automatically

2.7 Reset connected Servos to factory settings

KEY INFORMATION: The controller,  servopack  and servomotor  are reset individually in  MotionWorks IEC.

Servopack and Servomotor must be installed and wired.

Step Description Detail

1 Reboot controller CNFG on CNFG should remain on.  Discovers servos and LIO cards at power up.

2
Establish ethernet 

communication with controller

See procedure 1.4 - type controller IP address into Internet Explorer to open the 

controller's built in webserver.

3
Open MotionWorks IEC 

Hardware Configuration
Click the Hardware Configuration Icon to open

4 Connect to the controller
Enter the IP address of the controller.  "Connect".  In Configuration Comparison 

window, click "Use Autodiscovered Configuration" on right

5 Select required axis 
Hardware tree, Mechatrolink-II (Motion Engine), click on an axis that requires factory 

reset of amplifier or motor.

6 Reset servo parameters click Reset Default Pn Values

7 Reset absolute encoder click Reset Absolute Encoder

8 Repeat for each required axis Last 3 steps above. (This step does not apply to MP2600iec )

9 Online Save File -> save while still online in Hardware Configuration

10 Reboot system Online -> reboot controller.  Reboots controller and Sigma-5 Servos

11 Clear Possible Alarm A.CC0 If the alarm A.CC0 is encountered, see procedure to clear in Web Server

Page 17 of 24



MPiec Series QRG Rev 3.4

2.8 Clear Alarm A.810 (Initialize Absolute Encoders)

KEY INFORMATION

Alarm A.810 means that the absolute encoder of the servomotor lost the position 

during power off because BATTERY power was lost to the servomotor, invalidating 

the absolute position.

The alarm can by cleared by: 1) Web Server.  2) Y_ResetAbsoluteEncoder function 

block, 3) SigmaWin+ software, 3) Fn008 (Digital Operator). 

Step Description Detail

1
Establish ethernet 

communication with controller

See procedure 1.4 - type controller IP address into Internet Explorer to open the 

controller's built in webserver.

2
Start a new MotionWorks IEC 

Project

File -> New Project.  Select template according to controller type, OK.  File -> Save 

As.  Navigate to required directory and name the project.

3
Open MotionWorks IEC 

Hardware Configuration
Click the Hardware Configuration Icon to open

4 Connect to the controller
Enter the IP address of the controller.  Then click the "connect" button. Select "Use 

Online Configuration" on right.

5 Reset absolute encoder click Reset Absolute Encoder

6 Repeat for each required axis Last 3 steps above. (This step does not apply to MP2600iec )

7 Reboot system Online -> reboot controller.  Reboots controller and Sigma-5 Servos

2.9 Extract/Open the project stored in the controller

KEY INFORMATION: The project "source" must have been previously saved to the controller

The "upload" button will appear in the Resource dialog if the source exists

The source is uploaded in the same way as extracting a *.zwt (zipped) file.

1 Set Project IP Address See Procedure.  The webserver may remain open.

2 Open Resource Window
Online -> Project Control.  Resource window opens.  Resource is the controller 

(PLC).  The project is now communicating with the PLC.

3 Upload Project Source
"Upload" -> Project Source.  The new project closes,  click "No" to save changes to 

Untitled.  See procedure for opening zipped project.

4 Verify project IP address
See Procedure.  Project Tree Window -> Hardware Tab, R-Click "Resource" -> 

choose "Settings"

2.A Import configuration from controller to existing project

A project can be configured for one controller, and for any MPiec controller

Step Description Detail

1 Configure the Controller

Create a new project or open a project configured for the controller.  Go online in 

Hardware Configuration. Backup controller's existing data with 1. Disconnect, 2. 

online->controller configuration utilities, create archive.  Configure axes, user units, 

LIO, etc.  If possible, match axis names to existing project.  Delete any existing 

bootproject from controller.  Online save and reboot.  Go online again and use Test 

Move to be sure each connected axis is moves correctly. 

2 Open Existing Project

Best Practice - save under new name.  Note current axis names.  If axis names are 

not matched, then there will be much search and replace to update the project with 

new names.

3 Empty the offline configuration

Open Hardware Configuration. Stay OFFLINE.  Remove all axes from the hardware 

tree with right-click - remove.  Remove all LIO.  Under "Resource" select the 

controller type.  SAVE configuration. Only the offline controller type is important; 

the controller's existing online configuration will be used.

4
Import controller's configuration 

into template project

Open Hardware Configuration, set the IP address and go ONLINE.  At the dialogue, 

choose "use startup configuration" on the right side.  Online save and reboot.

5 Synchronize Axis Data

Open Global_Variables.  Axis variables may require datatype change from 

"AXIS_REF" to "AxisStruct" and adjust initial value of structure or initialize the 

AxisNum element.

6
Update POUs to use new axis 

names

Replace each  G_Axis variable to match the name of the axis variable.  Also adjust 

rung 4 to use the correct name for AX#_HBB and AX#_PON.

7 Resolve Errors Make and resolve any miscellanous errors that may result

8
Download the updated project to 

the "new" controller

Rebuild the entire project.  Resolve any compile errors.  Download and cold start.  

Then stop and warm start (warm start task must run).

9 Test the project Make, Download, Cold, Stop, Warm.  Operate the project in debug mode.

Page 18 of 24



MPiec Series QRG Rev 3.4

2.B Configure Axes / Servopacks

KEY INFORMATION: 

Servopack configuration depends on the servopack model. 

Common settings are shown below.

Set Programming Units

Click the configuration tab

Set the Load Type.  Set the mechanical gear ratio.  

Select measurement unit, then set Feed Constant (units moved per gearbox output 

shaft revolution)

Machine Cycle only applies to Load Type = Rotary.  Set to 360 for rotary tables with 

units of degrees.

Disable Overtravel Inputs

Click the I/O tab

Set over-travel parameters to "Set Signal Off"

Disable Absolute Encoder

Click the Absolute Encoder tab

Set Absolute Encoder Usage to "use absolute encoder as incremental encoder"

Set 3-phase SGDV servopack to run single phase

Click the Function tab

Set Power Selection to "Apply Single Phase Power"

Absolute Encoder Battery Alarm/Warining

Pn008

Regeneration Power

Pn600

Absolute Encoder Multi-Turn Limit

Pn205

File-> Save

If OFFLINE, use the menu Online - Controller Configuration Utilities, Send Offline Configuration

Cycle Power on controller and amplifiers. 

Clear any alarms under the "alarms" tab

2.C Download project to controller

Go online with a project (see procedure 1.6)

Click the "MAKE" button

A successful "Make" with zero errors is required before download.  Correct all errors 

as required.  

Option#2: Full Download (stop and restart)

Project Control -> Stop-> Download -> Download

Click the "cold" or "warm" button.  

Close the project control box.

Option#1: Quick Download

Project Control -> Download -> Download Changes

Close the project control box.
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2.C Set program to auto-start

KEY INFORMATION: 

The controller always starts the "boot project" saved in flash memory at power-up.

Project Control -> Stop-> Download -> 

Check "include bootproject"

Download

Close the project control box.

2.D Save a copy of the project on the controller for future upload

KEY INFORMATION: 

A separate file must be downloaded, called "Project Source"

Project Control -> Stop-> Download -> 

Check "Include Sources" to save a copy of the project for future upload

Check "user libraries", "Page Layouts", and "Backend Code"

Download

Close the project control box.

2.E Confirm motion is possible on each axis

Use Config tool "test move" tab under Mechatrolink

set test move parameters to appropriate value for machine

Default units are Motor Revolutions and Seconds.  Change units if desired.

2.F Update the program (configuration or code)

KEY INFORMATION: 

Configuration changes require an 1)online save followed by 2)Make and 

3)Download.

Code changes reequire Make and Download

In the Download dialog, check Bootproject to retain changes after power cycle

In the Download dialog, check Include Sources to apply changes to zipfile.zwt in 

project archive

2.G Apply Password Protection to program.

MotionWorks IEC- Express: There is no password protection at this time.

MotionWorks IEC- Pro: 

File - Password, enter and activate password

R-Click on an item in project tree, 
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MODBUS

Overview

Step Description Detail

1 Add slave device to controller (master)

Go Online.  Under Modbus TCP, "Add Slave Device".

Enter Name, IP Address of device.  Name the global status 

variable that will display the connection status of the device.  Set 

update interval at or higher than the task scan time.

2 Add input and output data blocks to the device

Click on the device under ModBus TCP.

Click "Add Data Block"

Enter the I/O Group name that will appear as a header in the 

global variable list for that data block.

Choose the desired function code.  FC#4 is Read Input 

Registers.  FC#16 is Write Multiple Registers

Starting address already includes any modbus offset, so use 

address 1 for the first modbus data in the device.

# of Items is number of modbus words (16 bit word).

3 Enable Slave Device

Some slave devices are enabled when powered on.  

When another MP2300Siec is used as a modbus slave, it must 

be enabled by checking "enable controller as a modbus slave"

4 Activate changes to controller*

(A) Save, (B) Make, (C) Download, (D) Cycle Power.  Be sure 

controller is in RUN mode.

If the slave device is another MP2300Siec, do the same to 

activate changes on the slave controller.

5 Verify communication to device

Monitor the staus variable that was named in Step 1.

Expect value of 16#1000 or 16#1400 indicating connected 

status.

6 Create variables in controller (master)

In global variable list, note the address range for each data block 

as given in the gray Group heading. (%IB for inputs, and %QB 

for outputs)

Create variables with addresses in the range listed.

R-click "create variable set" to create several variables quickly.

7 Create variables in controller (slave)

If the slave device is another MP2300Siec, also go to its global 

variable list.  

Note the address range for each data block given in the gray 

Group heading. (%IB for inputs, and %QB for outputs)

Create variables with addresses in the range listed.

R-click "create variable set" to create several variables quickly.

8 Activate changes to controller

Make and run the program with the new variabels.  Monitor the 

communication of variables and test operation of slave device.

If the data type is chosen as "word" or "byte", individual bits can 

be selected in the variable declaration window.  For example 

"Var.X0" for bit zero of Variable "Var".

Common Mistakes

1. The controller is not in RUN mode (see resource tab)

2. Variables have the wrong address, or wrong type (I or Q)

3. I/O Driver Error - Repeat step 4 (Save, Make, Download, Cycle Power)

*

Data is sent over ethernet using two possible protocols; ModBus/TCP and Ethernet/IP.  Modbus uses "Function 

Codes" and EIP uses "Instances" as channels of communication between the controller and another device.  

All configuration is accomplished using MotionWorks IEC Configuration Tool.

It is important to Save, Make, Download, Cycle Power in this order.  Save  creates controller configuration files, and 

also creates I/O drivers in for the program.  Make  is required before cycling power, or else the controller will run the 

old bootproject, which does not have the drivers to run the new hardware configuration (I/O driver Error).
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User Libraries

Overview

Create a Library
Step Description Detail

1
Rename the project and save in the Libraries 

folder (Optional, Best Practice)

File -> Save As.File -> Save Project As / Zip Project AsT

Navigate to Libraries folder

Edit the file name to reflect the intended usage as a user library and revision control.  For 

example, "TrainingLibrary_V001"

2
 Delete unnecessary POUs and datatypes 

(Optional, Best Practice)

In project tree leave one LD program POU with an instance of each user FU/FB.  

Leave one ST program POU with data initialization.  

Leave 1-2 tasks to run both programs (for compile).  I/O assigned to unused tasks must 

be reassigned.

3
Prefix all POUs and Datatypes (Optional, Best 

Practice)

Example Prefix: "YTTS_".  Typical to leave LD programs YTTS_Palette and YTTS_Init 

running in YTTS_Tsk, using YTTS_CustomDatatypes.

4 MAKE the library project
Click "MAKE" and resolve all errors.

A project that has only been renamed requires a new "MAKE"

5
Save the library project as ZIP (Optional, Best 

Practice) 

File -> Save Project As / Zip Project As...

Navigate to the Libraries folder (for organization purposes)

Choose ZIP as the file type

Best Practice: Do NOT change the name when zipping.  Change the name in Step1 and 

re-MAKE first.

Under "Zip Options"  check boxes for "User Libraries" and "Front-end Code".

Click the Zip button.

Single portable library file with revision name is produced

Use a Library
Step Description Detail

1 Acquire a ZWE (Express) or ZWT (Pro) file 

Use your own, or download from Yaskawa.com Product Page

Follow links to save the file

In Windows Explorer, copy the file to C:\Documents and Settings\All 

Users\Documents\MotionWorks IEC xxx\Libraries (For oranization purposes)

2 Unzip the library project to the library directory

In MotionWorks IEC... File-> Open Project / Unzip Project

Click "Yes" to unzip to the Library directory (File was copied here in previous step) or 

click "No" if opening directly from CD or Download folder

"Skip All" to Extracting Firmware Libraries dialog

"Yes to All" to Overwrite Page Layout

3 Check for Dependent Libraries

Project Tree -> Project Tab,  Expand Libraries folder

Take note of any User Libraries,  indicated by the "blue book" icon. Or special Firmware 

libraries such as "Ymotion", indicated by the "red book" icon

4 Start new / open existing project File -> New,   or File -> Open

5 Insert the Library and any dependent libraries

In Project Tree, "Project" tab, R-Click "Libraries" -> Insert -> User Libraries

Navigate to find the Library (if you unzipped it to the  "libraries" folder, you will see it right 

away)

Also insert any dependent libraries noted in Step 3

6 Delete duplicate project data types

In Project Tree, "Project" tab, expand "Data Types" folder for both the user library and 

the project library.

Delete any duplicates of "PLCTaskInfoTypes" or "MotionBlockTypes" from the project 

library.

R-click  -> delete (or open, delete text)

These data types are already defined within the imported library.  Repeating the 

definition here causes compile errors since the same data types would be defined two 

times, even though the definitions are identical. 

7 Use FB from new group in edit wizard

Click on programming worksheet whitespace.

Open Edit Wizard and the group dropdown list will have the library name.

User Library blocks appear as Blue by default

Help for Yaskawa "Application Code Toolbox" user libraries is available on the website, 

but is not integrated with the Right-Click menu as it is for the pink colored Firmware 

Library function blocks.

User Libraries are just normal project files imported into another project file as a library.

"Application Code Toolboxes" from Yaskawa are simply User Libraries created at Yaskawa

* If you wish to use a Yaskawa "Application Code Toolbox" user library in a project along with your own custom library project, you must insert the 

Yaskawa library  directly in your custom library project.  You may NOT insert both libraries individually into a new project.

A project with two libraries that both have the same datatype definitions will not compile, and so both libraries must be combined into a single 

library.  

Specifically, your library project will have the MotionBlockTypes and PLCTaskInfoTypes defined, which are also defined in a Yaskawa library, 

such as PLCopenPlus Toolbox or Cam Toolbox.  Insert one library into another and delete the duplicate datatypes for a successful MAKE.
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OPC Server

Overview

Step Description Detail

1 Install the OPC Server software

Obtain software PDE-U-OPCPA and install.  A 

serial number is required.  With no serial number 

it functions as a 30-day demo.

2 Confirm ethernet communication between the PC with OPC Server installed and with the controller(s)

Connect simultaneously to each controller via 

the web interface.  Note the IP address of each 

controller.

3 Disable firewall
Open windows network connections and set to 

off

4 Configure OPC Server

Run OPC Configurator: R-click OpcProject, 

select resource type = MP2000, click settings, 

set IP address of controller, rename "new 

resource" as desired by clicking 2x slowly.  

Repeat above for additional controllers.

5 Run Server
Start-Program Files - Yaskawa - MWIEC OPC 

Server - OPC Server 2.1

6 Monitor Server

R-click green OPC icon in system tray, select 

"Info - Statistics".  This tells you connection 

status of "resources" (controllers) and "clients" 

(windows software).  Repeat above to refresh

The OPC Server is a Yaskawa software package that communicates variables between 

the controller and the Windows environment according to the OPC standard.  This allows 

a "client" software package to have easy access to the controller data.
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Logic Analyzer
Overview

Step Description Detail

1 Add Variables

Toggle Debug Mode = ON.

Right-click a variable and select "Add to Logic Analyzer".  

The variable may be selected from the code, watch page, 

or variable list.

2 Adjust Window size

menu "View" - Logic Analyzer.  By default the window is 

docked and very small.  Right-click on the window title bar 

and uncheck "allow docking".  Resize the window by click 

& drag on corners.

3 Open Trigger Configuration
Right-click the tab in the logic analyzer window 

"Configuration:Resource" and select Trigger Configuration.

4 Sampling

Time [in ms] between cycles is the task "interval", or scan 

time.  ( To view the task interval, toggle Debug Mode = 

OFF, Right-click a task, and choose Settings).  "Pre-

recording cycles" buffers a number of samples before the 

trigger condition is true.  Post-recording cycles is the 

number of samples after the trigger is true. 

5 Trigger conditions

The controller will start to capture the value of the added 

variables when the Pre-recording cycles buffer is full and 

the Trigger conditions are met.  Select one of the variables 

from the dropdown list, an Operator, and a variable.  A 

literal such as LREAL#0.0 or TRUE may also be entered 

directly.

6 Data collection

In MWIEC-Pro, the data can be collected synchronous with 

any of the cyclic tasks.  The interval of the selected task x 

the total Pre/Post recording cycles gives the total time of 

the logic analyzer.

7 Capture Data

Right-click the tab in the logic analyzer window 

"Configuration:Resource" and select Start Recording.  Pro 

also has a handy button with the red "record" dot on it.

8 Zoom

Click and drag on the horizontal axis or vertical axis.  Left 

click & drag zooms one half, Right click & drag zooms the 

other half.

9 Cursors

Move the mouse pointer near the horizontal or vertical 

axis.  The mouse pointer icon changes.  Click and drag a 

single cursor onto the display area.

Logic analyzer graphs any controller variable at a cyclic task rate
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